use strict;
my $str = 'Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\\"1234567890123456\\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa';
my $regex = qr/\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d/p;
my $subst = '$1******$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";