const regex = /\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d([0-9]{6})([0-9]{0,16})([0-9]{4})\\d', 'g')
const str = `Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\\"1234567890123456\\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa`;
const subst = `$1******$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);