$re = '/\d([0-9]{6})([0-9]{0,16})([0-9]{4})\d/';
$str = 'Aaaa bbbb aaa=1234567890123456 fdfdfd=aaa
Aaaa bbbb aaa=\\"1234567890123456\\" fdfdfd=aaa
Aaaa bbbb aaa=5155900762048745 fdfdfd=aaa';
$subst = "$1******$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;