import Foundation
let pattern = #"^((?:[ \-]?[A-Z][a-z]+|[A-Z][a-z]?\.?)+)(?: ?[A-Z]\.?)* ([A-Za-z]{,3}(?:[ \-]?[A-Z]'?[A-Z]?[a-z]+\.?,?)+[A-Z \-.]*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Joel Dorfman
David C. Thomas
George Stager III
Jerome Jay Allen
Shaunda Richardson-Snell
Shelley J. O'Brien
Anthony Stiel, Jr.
James Van Harn II
L. Marcinkowski
S.M. Rutkowski
S. M. Rutkowski
E. Todd Brown
Marc A. ORourke
James CW Roberts III
Holly A. McClellan
Thomas-Robert Peterson
Annette DeLaHuerta
Wm. Craig Faulk
JD Haughey
Adam de Angeli
Keith den Hollander
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)