import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[ \\-]?[A-Z][a-z]+|[A-Z][a-z]?\\.?)+)(?: ?[A-Z]\\.?)* ([A-Za-z]\\{,3\\}(?:[ \\-]?[A-Z]'?[A-Z]?[a-z]+\\.?,?)+[A-Z \\-.]*)$";
final String string = "Joel Dorfman\n"
+ "David C. Thomas\n"
+ "George Stager III\n"
+ "Jerome Jay Allen\n"
+ "Shaunda Richardson-Snell\n"
+ "Shelley J. O'Brien\n"
+ "Anthony Stiel, Jr.\n"
+ "James Van Harn II\n"
+ "L. Marcinkowski\n"
+ "S.M. Rutkowski\n"
+ "S. M. Rutkowski\n"
+ "E. Todd Brown\n"
+ "Marc A. ORourke\n"
+ "James CW Roberts III\n"
+ "Holly A. McClellan\n"
+ "Thomas-Robert Peterson\n"
+ "Annette DeLaHuerta\n"
+ "Wm. Craig Faulk\n"
+ "JD Haughey\n"
+ "Adam de Angeli\n"
+ "Keith den Hollander";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}