const regex = new RegExp('^((?:[ \\-]?[A-Z][a-z]+|[A-Z][a-z]?\\.?)+)(?: ?[A-Z]\\.?)* ([A-Za-z]{,3}(?:[ \\-]?[A-Z]\\'?[A-Z]?[a-z]+\\.?,?)+[A-Z \\-.]*)$', 'gm')
const str = `Joel Dorfman
David C. Thomas
George Stager III
Jerome Jay Allen
Shaunda Richardson-Snell
Shelley J. O'Brien
Anthony Stiel, Jr.
James Van Harn II
L. Marcinkowski
S.M. Rutkowski
S. M. Rutkowski
E. Todd Brown
Marc A. ORourke
James CW Roberts III
Holly A. McClellan
Thomas-Robert Peterson
Annette DeLaHuerta
Wm. Craig Faulk
JD Haughey
Adam de Angeli
Keith den Hollander`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}