# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:[ \-]?[A-Z][a-z]+|[A-Z][a-z]?\.?)+)(?: ?[A-Z]\.?)* ([A-Za-z]{,3}(?:[ \-]?[A-Z]'?[A-Z]?[a-z]+\.?,?)+[A-Z \-.]*)$"
test_str = ("Joel Dorfman\n"
"David C. Thomas\n"
"George Stager III\n"
"Jerome Jay Allen\n"
"Shaunda Richardson-Snell\n"
"Shelley J. O'Brien\n"
"Anthony Stiel, Jr.\n"
"James Van Harn II\n"
"L. Marcinkowski\n"
"S.M. Rutkowski\n"
"S. M. Rutkowski\n"
"E. Todd Brown\n"
"Marc A. ORourke\n"
"James CW Roberts III\n"
"Holly A. McClellan\n"
"Thomas-Robert Peterson\n"
"Annette DeLaHuerta\n"
"Wm. Craig Faulk\n"
"JD Haughey\n"
"Adam de Angeli\n"
"Keith den Hollander")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.