$re = '/\b(?\'verb\'build|make|implementing)\s*
(?\'build\'(?:(?!(?&verb)).)*?)
(?=\s*\b(?:in|on)\b)
/ixs';
$str = 'Projects I\'ve built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing "Natural Language Processing" algorithms in PHP when I have time. I\'ll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);