using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?'verb'build|make|implementing)\s*
(?'build'(?:(?!(?&verb)).)*?)
(?=\s*\b(?:in|on)\b)
";
string input = @"Projects I've built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing ""Natural Language Processing"" algorithms in PHP when I have time. I'll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}