#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ixs)\b(?'verb'build|make|implementing)\s*" & @CRLF & _
"(?'build'(?:(?!(?&verb)).)*?) " & @CRLF & _
"(?=\s*\b(?:in|on)\b)" & @CRLF & _
""
Local $sString = "Projects I've built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing "Natural Language Processing" algorithms in PHP when I have time. I'll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")