import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?'verb'build|make|implementing)\\s*\n"
+ "(?'build'(?:(?!(?&verb)).)*?) \n"
+ "(?=\\s*\\b(?:in|on)\\b)\n";
final String string = "Projects I've built & Plan to build. HackMatch.io (May 2020 onward), As of October 2020, I intend to start implementing \"Natural Language Processing\" algorithms in PHP when I have time. I'll then use PHP to upload the results to big data tech (e.g. BigQuery) to create some data visualizations.";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}