import Foundation
let pattern = #"1?\W*([2-9][0-8][0-9])\W*([2-9][0-9]{2})\W*([0-9]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
AlexCrawford@dayrep.com+1 (208) 264-9063
StefanijaNovosel@teleworm.us1 518 487 4865
someemail@me.comss(845) 858-7707
JakobCJakobsen@einrot.com+1 (845) 858-7707
johndoe@email.com1234567890
304-438-2648SandraCTaylor@dayrep.com
978-243-8596JuanPerez@teleworm.us
413-259-3637BuiQuynhChan@fleckens.hu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}