import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "1?\\W*([2-9][0-8][0-9])\\W*([2-9][0-9]{2})\\W*([0-9]{4})";
final String string = "AlexCrawford@dayrep.com+1 (208) 264-9063\n"
+ "StefanijaNovosel@teleworm.us1 518 487 4865\n"
+ "someemail@me.comss(845) 858-7707\n"
+ "JakobCJakobsen@einrot.com+1 (845) 858-7707\n"
+ "johndoe@email.com1234567890\n"
+ "304-438-2648SandraCTaylor@dayrep.com\n"
+ "978-243-8596JuanPerez@teleworm.us\n"
+ "413-259-3637BuiQuynhChan@fleckens.hu";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}