package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`1?\W*([2-9][0-8][0-9])\W*([2-9][0-9]{2})\W*([0-9]{4})`)
var str = `AlexCrawford@dayrep.com+1 (208) 264-9063
StefanijaNovosel@teleworm.us1 518 487 4865
someemail@me.comss(845) 858-7707
JakobCJakobsen@einrot.com+1 (845) 858-7707
johndoe@email.com1234567890
304-438-2648SandraCTaylor@dayrep.com
978-243-8596JuanPerez@teleworm.us
413-259-3637BuiQuynhChan@fleckens.hu`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}