const regex = new RegExp('1?\\W*([2-9][0-8][0-9])\\W*([2-9][0-9]{2})\\W*([0-9]{4})', '')
const str = `AlexCrawford@dayrep.com+1 (208) 264-9063
StefanijaNovosel@teleworm.us1 518 487 4865
someemail@me.comss(845) 858-7707
JakobCJakobsen@einrot.com+1 (845) 858-7707
johndoe@email.com1234567890
304-438-2648SandraCTaylor@dayrep.com
978-243-8596JuanPerez@teleworm.us
413-259-3637BuiQuynhChan@fleckens.hu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}