// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<emoji>(:)([a-zA-Z0-9_]+)(:))|(?<embed_emoji>(\[)([a-zA-Z0-9_]+)(\])\([^()]*\))").unwrap();
let string = ":emojisomeothertext:
:someothertextemoji:
:someemojiothertext:
:emoji:
text with no emoji
text with :emoji_some_text: and no emoji
text with :emoji:
text with [ImageEmoji]
These image [emoji]'s were added due to vesktop making emojis into embeds like that.
This regex isn't perfect but i doubt anyoue would post emojis like: \"[this:\" anyway.
[HuTaoPeek](https://cdn.discordapp.com/emojis/844898526243586049.webp?size=512&name=HuTaoPeek)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}