const regex = new RegExp('(?<emoji>(:)([a-zA-Z0-9_]+)(:))|(?<embed_emoji>(\\[)([a-zA-Z0-9_]+)(\\])\\([^()]*\\))', 'gm')
const str = `:emojisomeothertext:
:someothertextemoji:
:someemojiothertext:
:emoji:
text with no emoji
text with :emoji_some_text: and no emoji
text with :emoji:
text with [ImageEmoji]
These image [emoji]'s were added due to vesktop making emojis into embeds like that.
This regex isn't perfect but i doubt anyoue would post emojis like: "[this:" anyway.
[HuTaoPeek](https://cdn.discordapp.com/emojis/844898526243586049.webp?size=512&name=HuTaoPeek)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}