import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<emoji>(:)([a-zA-Z0-9_]+)(:))|(?<embed_emoji>(\\[)([a-zA-Z0-9_]+)(\\])\\([^()]*\\))";
final String string = ":emojisomeothertext:\n"
+ ":someothertextemoji:\n"
+ ":someemojiothertext:\n"
+ ":emoji:\n"
+ "text with no emoji\n"
+ "text with :emoji_some_text: and no emoji\n"
+ "text with :emoji:\n"
+ "text with [ImageEmoji]\n"
+ "These image [emoji]'s were added due to vesktop making emojis into embeds like that.\n"
+ "This regex isn't perfect but i doubt anyoue would post emojis like: \"[this:\" anyway.\n"
+ "[HuTaoPeek](https://cdn.discordapp.com/emojis/844898526243586049.webp?size=512&name=HuTaoPeek)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}