use strict;
my $str = ':emojisomeothertext:
:someothertextemoji:
:someemojiothertext:
:emoji:
text with no emoji
text with :emoji_some_text: and no emoji
text with :emoji:
text with [ImageEmoji]
These image [emoji]\'s were added due to vesktop making emojis into embeds like that.
This regex isn\'t perfect but i doubt anyoue would post emojis like: "[this:" anyway.
[HuTaoPeek](https://cdn.discordapp.com/emojis/844898526243586049.webp?size=512&name=HuTaoPeek)';
my $regex = qr/(?<emoji>(:)([a-zA-Z0-9_]+)(:))|(?<embed_emoji>(\[)([a-zA-Z0-9_]+)(\])\([^()]*\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}