re = /https:\/\/cdn07\.icims\.com\/a\/images\.icims\.com\/content\/platform_[0-9\.]+\/script[\/[a-z0-9\/]+\.js/
str = 'https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/lib/domreplacement/domreplacement.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/common/icims.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/portal/utils.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end