const regex = /https:\/\/cdn07\.icims\.com\/a\/images\.icims\.com\/content\/platform_[0-9\.]+\/script[\/[a-z0-9\/]+\.js/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/cdn07\\.icims\\.com\\\/a\\\/images\\.icims\\.com\\\/content\\\/platform_[0-9\\.]+\\\/script[\\\/[a-z0-9\\\/]+\\.js', 'g')
const str = `https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/lib/domreplacement/domreplacement.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/common/icims.js
https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/portal/utils.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}