import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https:\\/\\/cdn07\\.icims\\.com\\/a\\/images\\.icims\\.com\\/content\\/platform_[0-9\\.]+\\/script[\\/[a-z0-9\\/]+\\.js";
final String string = "https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/lib/domreplacement/domreplacement.js\n"
+ "https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/common/icims.js\n"
+ "https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/portal/utils.js";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}