#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "https:\/\/cdn07\.icims\.com\/a\/images\.icims\.com\/content\/platform_[0-9\.]+\/script[\/[a-z0-9\/]+\.js"
Local $sString = "https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/lib/domreplacement/domreplacement.js" & @CRLF & _
"https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/common/icims.js" & @CRLF & _
"https://cdn07.icims.com/a/images.icims.com/content/platform_103.1.170919.1505827181/script/portal/utils.js"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")