// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$
").unwrap();
let string = "Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}