# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$\n")
test_str = ("Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd\n"
"Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd\n"
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd\n\n"
"Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.