package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$
`)
var str = `Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd
Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd
Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}