#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>all|tx\d{0,3}|lay\d{0,3}|c0\d{1,3}|c[^0]\d{1,2}?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$" & @CRLF & _
""
Local $sString = "Obam_9781524763138_all_tcx_r3 Folder/Obam_9781524763138_all_0p_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx1_r3 Folder/Obam_9781524763138_all_1p_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_2p_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_all_123p_r3.indd" & @CRLF & _
"Obam_9781524763138_all_tcx123 Folder/Obam_9781524763138_tx_xp_r3.indd" & @CRLF & _
"" & @CRLF & _
"Obam_9781524763138_all_tcx1234_r3 Folder/Obam_9781524763138_all_tcx1234_r3.indd" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")