// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$").unwrap();
let string = "https://workdone.myxteam.com/project/5427/kanban
https://workdone.myxteam.com/project/5427/table
https://workdone.myxteam.com/project/
https://workdone.myxteam.com/project/5427
https://workdone.myxteam.com/project/5427/
http://workdone.myxteam.com/project/5427/task/12715709";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}