#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$"
Local $sString = "https://workdone.myxteam.com/project/5427/kanban" & @CRLF & _
"https://workdone.myxteam.com/project/5427/table" & @CRLF & _
"https://workdone.myxteam.com/project/" & @CRLF & _
"https://workdone.myxteam.com/project/5427" & @CRLF & _
"https://workdone.myxteam.com/project/5427/" & @CRLF & _
"" & @CRLF & _
"http://workdone.myxteam.com/project/5427/task/12715709"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")