package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$`)
var str = `https://workdone.myxteam.com/project/5427/kanban
https://workdone.myxteam.com/project/5427/table
https://workdone.myxteam.com/project/
https://workdone.myxteam.com/project/5427
https://workdone.myxteam.com/project/5427/
http://workdone.myxteam.com/project/5427/task/12715709`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}