using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/workdone\.myxteam\.com\/project\/([0-9]+)(\/)?(kanban|user|table|calendar|gantt|dasboard)?$";
string input = @"https://workdone.myxteam.com/project/5427/kanban
https://workdone.myxteam.com/project/5427/table
https://workdone.myxteam.com/project/
https://workdone.myxteam.com/project/5427
https://workdone.myxteam.com/project/5427/
http://workdone.myxteam.com/project/5427/task/12715709";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}