const regex = /^(?<is_hidden>\.?)(?:(?<timestamp>\d+)\-)?(?<name>[\w\x27\s]+\-?)+\-(?<content_removed_version>\d+(?:\(\w+\))?)(?<extensions>[\.[[:alpha:]]+\.?)*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<is_hidden>\\.?)(?:(?<timestamp>\\d+)\\-)?(?<name>[\\w\\x27\\s]+\\-?)+\\-(?<content_removed_version>\\d+(?:\\(\\w+\\))?)(?<extensions>[\\.[[:alpha:]]+\\.?)*$', 'g')
const str = `2023-make_test-00.make`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}