using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<is_hidden>\.?)(?:(?<timestamp>\d+)\-)?(?<name>[\w\x27\s]+\-?)+\-(?<content_removed_version>\d+(?:\(\w+\))?)(?<extensions>[\.[[:alpha:]]+\.?)*$";
string input = @"2023-make_test-00.make";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}