package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?<is_hidden>\.?)(?:(?<timestamp>\d+)\-)?(?<name>[\w\x27\s]+\-?)+\-(?<content_removed_version>\d+(?:\(\w+\))?)(?<extensions>[\.[[:alpha:]]+\.?)*$`)
var str = `2023-make_test-00.make`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}