#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?<is_hidden>\.?)(?:(?<timestamp>\d+)\-)?(?<name>[\w\x27\s]+\-?)+\-(?<content_removed_version>\d+(?:\(\w+\))?)(?<extensions>[\.[[:alpha:]]+\.?)*$"
Local $sString = "2023-make_test-00.make"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")