// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(22[4-9]|23[0-9])\.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[2-9])\.0\.0").unwrap();
let string = "252.165.1.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}