using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(22[4-9]|23[0-9])\.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[2-9])\.0\.0";
string input = @"252.165.1.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}