package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(22[4-9]|23[0-9])\.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[2-9])\.0\.0`)
var str = `252.165.1.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}