re = /(22[4-9]|23[0-9])\.(25[0-5]|2[0-4][0-9]|1[0-9][0-9]|[1-9]?[2-9])\.0\.0/m
str = '252.165.1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end