// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"frame_\d+_time_\d+(_\d\d){5}\.\d+_exp_-?\d+_ag_-?\d+\.\d+_dg_-?\d+\.?\d+_exp_st_\d+_wb_st_\d+_foc_\d+_o[lr]t_dgRGGB_\d+.\d+.\d+.\d+_rFix_-?\d+_bFix_-?\d+[.](pgm|jpg)").unwrap();
let string = "frame_00091_time_2017_09_19_15_42_43.649_exp_40000_ag_6.5_dg_-1.0_exp_st_0_wb_st_1_foc_1_ort_dgRGGB_139.100.100.181_rFix_0_bFix_0.pgm";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}