const regex = new RegExp('frame_\\d+_time_\\d+(_\\d\\d){5}\\.\\d+_exp_-?\\d+_ag_-?\\d+\\.\\d+_dg_-?\\d+\\.?\\d+_exp_st_\\d+_wb_st_\\d+_foc_\\d+_o[lr]t_dgRGGB_\\d+.\\d+.\\d+.\\d+_rFix_-?\\d+_bFix_-?\\d+[.](pgm|jpg)', 'g')
const str = `frame_00091_time_2017_09_19_15_42_43.649_exp_40000_ag_6.5_dg_-1.0_exp_st_0_wb_st_1_foc_1_ort_dgRGGB_139.100.100.181_rFix_0_bFix_0.pgm`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}