re = /frame_\d+_time_\d+(_\d\d){5}\.\d+_exp_-?\d+_ag_-?\d+\.\d+_dg_-?\d+\.?\d+_exp_st_\d+_wb_st_\d+_foc_\d+_o[lr]t_dgRGGB_\d+.\d+.\d+.\d+_rFix_-?\d+_bFix_-?\d+[.](pgm|jpg)/
str = 'frame_00091_time_2017_09_19_15_42_43.649_exp_40000_ag_6.5_dg_-1.0_exp_st_0_wb_st_1_foc_1_ort_dgRGGB_139.100.100.181_rFix_0_bFix_0.pgm'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end