$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[\w@.-_&%~]{8,16}$/m';
$str = '1234qwe@
1234qwe@
1234qwe@
222kkk
12222kkkk
12222Kkk~.k
asAB12~~
asAB1234
//minimo 8 aracteres, maximo 16 y debe incluir minusculas, mayusculas, digitos y un caracter especial. Todo sin espacios';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);