import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[\\w@.-_&%~]{8,16}$";
final String string = "1234qwe@\n"
+ "1234qwe@ \n"
+ " 1234qwe@\n"
+ "222kkk\n"
+ "12222kkkk\n"
+ "12222Kkk~.k\n"
+ "asAB12~~\n"
+ "asAB1234 \n"
+ "//minimo 8 aracteres, maximo 16 y debe incluir minusculas, mayusculas, digitos y un caracter especial. Todo sin espacios";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}