#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[\w@.-_&%~]{8,16}$"
Local $sString = "1234qwe@" & @CRLF & _
"1234qwe@ " & @CRLF & _
" 1234qwe@" & @CRLF & _
"222kkk" & @CRLF & _
"12222kkkk" & @CRLF & _
"12222Kkk~.k" & @CRLF & _
"asAB12~~" & @CRLF & _
"asAB1234 " & @CRLF & _
"//minimo 8 aracteres, maximo 16 y debe incluir minusculas, mayusculas, digitos y un caracter especial. Todo sin espacios"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")