use strict;
my $str = '1234qwe@
1234qwe@
1234qwe@
222kkk
12222kkkk
12222Kkk~.k
asAB12~~
asAB1234
//minimo 8 aracteres, maximo 16 y debe incluir minusculas, mayusculas, digitos y un caracter especial. Todo sin espacios';
my $regex = qr/^(?=.*[a-z])(?=.*[A-Z])(?=.*[0-9])[\w@.-_&%~]{8,16}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}