# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\/[0-9]{4}\/[0-9]{2}\/[0-9]{2}\/([A-Z0-9]*)\_"
test_str = ("/politica/coronavirus-en-la-argentina-la-encrucijada-de-la-cuarentena-el-choque-de-posturas-entre-ciudad-provincia-y-nacion/2020/07/29/X7XAC7UIQZD45HTHV7A4D3GDCA_story/\n\n"
"/videos/musica/video-carmen-barbieri-debuto-en-el-cantando-2020-con-una-cancion-de-sergio-denis/2020/07/29/MRJEHI4CFBALDMGDKDMOJS3EFQ_story/\n\n"
"/fotos/deportes/titulo-galería/2020/07/29/MRJEHI4CFBALREEGDFGDMOJS3EFQ_story/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.