use strict;
my $str = '/politica/coronavirus-en-la-argentina-la-encrucijada-de-la-cuarentena-el-choque-de-posturas-entre-ciudad-provincia-y-nacion/2020/07/29/X7XAC7UIQZD45HTHV7A4D3GDCA_story/
/videos/musica/video-carmen-barbieri-debuto-en-el-cantando-2020-con-una-cancion-de-sergio-denis/2020/07/29/MRJEHI4CFBALDMGDKDMOJS3EFQ_story/
/fotos/deportes/titulo-galería/2020/07/29/MRJEHI4CFBALREEGDFGDMOJS3EFQ_story/';
my $regex = qr/\/[0-9]{4}\/[0-9]{2}\/[0-9]{2}\/([A-Z0-9]*)\_/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}