using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/[0-9]{4}\/[0-9]{2}\/[0-9]{2}\/([A-Z0-9]*)\_";
string input = @"/politica/coronavirus-en-la-argentina-la-encrucijada-de-la-cuarentena-el-choque-de-posturas-entre-ciudad-provincia-y-nacion/2020/07/29/X7XAC7UIQZD45HTHV7A4D3GDCA_story/
/videos/musica/video-carmen-barbieri-debuto-en-el-cantando-2020-con-una-cancion-de-sergio-denis/2020/07/29/MRJEHI4CFBALDMGDKDMOJS3EFQ_story/
/fotos/deportes/titulo-galería/2020/07/29/MRJEHI4CFBALREEGDFGDMOJS3EFQ_story/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}