import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/[0-9]{4}\\/[0-9]{2}\\/[0-9]{2}\\/([A-Z0-9]*)\\_";
final String string = "/politica/coronavirus-en-la-argentina-la-encrucijada-de-la-cuarentena-el-choque-de-posturas-entre-ciudad-provincia-y-nacion/2020/07/29/X7XAC7UIQZD45HTHV7A4D3GDCA_story/\n\n"
+ "/videos/musica/video-carmen-barbieri-debuto-en-el-cantando-2020-con-una-cancion-de-sergio-denis/2020/07/29/MRJEHI4CFBALDMGDKDMOJS3EFQ_story/\n\n"
+ "/fotos/deportes/titulo-galería/2020/07/29/MRJEHI4CFBALREEGDFGDMOJS3EFQ_story/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}